CRAN Package Check Results for Package surveillance

Last updated on 2021-07-25 09:50:37 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.19.1 72.74 557.26 630.00 NOTE
r-devel-linux-x86_64-debian-gcc 1.19.1 53.70 415.31 469.01 NOTE
r-devel-linux-x86_64-fedora-clang 1.19.1 748.81 NOTE
r-devel-linux-x86_64-fedora-gcc 1.19.1 761.15 OK
r-devel-windows-x86_64 1.19.1 85.00 361.00 446.00 NOTE --no-vignettes
r-devel-windows-x86_64-gcc10-UCRT 1.19.1 NOTE
r-patched-linux-x86_64 1.19.1 80.13 532.30 612.43 NOTE
r-patched-solaris-x86 1.19.1 883.40 NOTE
r-release-linux-x86_64 1.19.1 58.30 531.41 589.71 NOTE
r-release-macos-arm64 1.19.1 NOTE
r-release-macos-x86_64 1.19.1 NOTE
r-release-windows-ix86+x86_64 1.19.1 135.00 527.00 662.00 NOTE --no-vignettes
r-oldrel-macos-x86_64 1.19.1 NOTE
r-oldrel-windows-ix86+x86_64 1.19.1 134.00 725.00 859.00 NOTE --no-vignettes

Check Details

Version: 1.19.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'INLA'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.19.1
Check: installed package size
Result: NOTE
     installed size is 8.2Mb
     sub-directories of 1Mb or more:
     R 1.7Mb
     doc 2.4Mb
     libs 1.6Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.19.1
Flags: --no-vignettes
Check: installed package size
Result: NOTE
     installed size is 7.6Mb
     sub-directories of 1Mb or more:
     R 1.7Mb
     doc 2.4Mb
     libs 1.0Mb
Flavors: r-devel-windows-x86_64, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.19.1
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'spdep', 'INLA', 'runjags'
Flavor: r-release-macos-arm64

Version: 1.19.1
Check: Rd cross-references
Result: NOTE
    Packages unavailable to check Rd xrefs: ‘spdep’, ‘runjags’
Flavor: r-release-macos-arm64

Version: 1.19.1
Check: re-building of vignette outputs
Result: NOTE
    Error(s) in re-building vignettes:
    --- re-building ‘glrnb.Rnw’ using Sweave
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type ‘help(surveillance)’.
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting glm.nb model with alpha=0.225966923076071
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    glrnb: Fitting Poisson model because alpha == 0
    --- finished re-building ‘glrnb.Rnw’
    
    --- re-building ‘hhh4.Rnw’ using Sweave
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type ‘help(surveillance)’.
    Doing computations: FALSE
    --- finished re-building ‘hhh4.Rnw’
    
    --- re-building ‘monitoringCounts.Rnw’ using Sweave
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type ‘help(surveillance)’.
    Loading required package: splines
    Loading required package: gamlss.data
    
    Attaching package: ‘gamlss.data’
    
    The following object is masked from ‘package:datasets’:
    
     sleep
    
    Loading required package: gamlss.dist
    Loading required package: MASS
    Loading required package: nlme
    Loading required package: parallel
     ********** GAMLSS Version 5.3-4 **********
    For more on GAMLSS look at https://www.gamlss.com/
    Type gamlssNews() to see new features/changes/bug fixes.
    
    Warning in model.matrix.default(mt, mf, contrasts) :
     non-list contrasts argument ignored
    Warning in model.matrix.default(mt, mf, contrasts) :
     non-list contrasts argument ignored
    --- finished re-building ‘monitoringCounts.Rnw’
    
    --- re-building ‘surveillance.Rnw’ using Sweave
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type ‘help(surveillance)’.
    Doing computations: FALSE
    --- finished re-building ‘surveillance.Rnw’
    
    --- re-building ‘hhh4_spacetime.Rnw’ using knitr
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type 'help(surveillance)'.
    Doing computations: FALSE
    Loading required namespace: spdep
    Failed with error: 'there is no package called 'spdep''
    Quitting from lines 264-266 (hhh4_spacetime.Rnw)
    Error: processing vignette 'hhh4_spacetime.Rnw' failed with diagnostics:
    package "spdep" is required to derive adjacencies from SpatialPolygons
    --- failed re-building ‘hhh4_spacetime.Rnw’
    
    --- re-building ‘twinSIR.Rnw’ using knitr
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type 'help(surveillance)'.
    Doing computations: FALSE
    Warning in `[.epidata`(x, 1:5, , drop = FALSE) :
     dropped class "epidata": subsetting blocks not allowed
    Initialized 1 log-baseline interval: 0.00 92.55
    Initial parameter vector: 1 1 1 1 0
    Computing OSAIC weights for 4 epidemic covariates based on 1000 simulations ...
    Initialized 1 log-baseline interval: 0.00 92.55
    Initial parameter vector: 1 1 1 1 1 1 0
    Computing OSAIC weights for 4 epidemic covariates based on 1000 simulations ...
    --- finished re-building ‘twinSIR.Rnw’
    
    --- re-building ‘twinstim.Rnw’ using knitr
    Loading required package: sp
    Loading required package: xtable
    This is surveillance 1.19.1. For overview type 'help(surveillance)'.
    Doing computations: FALSE
    Loading required namespace: spdep
    Failed with error: 'there is no package called 'spdep''
    Quitting from lines 688-692 (twinstim.Rnw)
    Error: processing vignette 'twinstim.Rnw' failed with diagnostics:
    package "spdep" is required to derive adjacencies from SpatialPolygons
    --- failed re-building ‘twinstim.Rnw’
    
    SUMMARY: processing the following files failed:
     ‘hhh4_spacetime.Rnw’ ‘twinstim.Rnw’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-arm64