CRAN Package Check Results for Package pkgdepends

Last updated on 2021-09-23 10:53:39 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.2 17.14 112.91 130.05 OK
r-devel-linux-x86_64-debian-gcc 0.1.2 14.03 83.34 97.37 OK
r-devel-linux-x86_64-fedora-clang 0.1.2 162.77 OK
r-devel-linux-x86_64-fedora-gcc 0.1.2 159.18 OK
r-devel-windows-x86_64 0.1.2 23.00 117.00 140.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.1.2 ERROR
r-patched-linux-x86_64 0.1.2 15.83 106.68 122.51 OK
r-patched-solaris-x86 0.1.2 204.70 OK
r-release-linux-x86_64 0.1.2 16.36 106.68 123.04 OK
r-release-macos-arm64 0.1.2 OK
r-release-macos-x86_64 0.1.2 OK
r-release-windows-ix86+x86_64 0.1.2 32.00 123.00 155.00 OK
r-oldrel-macos-x86_64 0.1.2 OK
r-oldrel-windows-ix86+x86_64 0.1.2 22.00 124.00 146.00 OK

Check Details

Version: 0.1.2
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'spelling'
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.2
Check: tests
Result: ERROR
     Running 'testthat.R'
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(pkgdepends)
     >
     > Sys.setenv(R_USER_CACHE_DIR = tempdir())
     > test_check("pkgdepends")
     ! Using bundled GitHub PAT. Please add your own PAT using `gitcreds::gitcreds_set()`.
     WARNING: Rtools is required to build R packages, but is not currently installed.
    
     Please download and install Rtools 4.0 from https://cran.r-project.org/bin/windows/Rtools/.
     WARNING: Rtools is required to build R packages, but is not currently installed.
    
     Please download and install Rtools 4.0 from https://cran.r-project.org/bin/windows/Rtools/.
     WARNING: Rtools is required to build R packages, but is not currently installed.
    
     Please download and install Rtools 4.0 from https://cran.r-project.org/bin/windows/Rtools/.
     WARNING: Rtools is required to build R packages, but is not currently installed.
    
     Please download and install Rtools 4.0 from https://cran.r-project.org/bin/windows/Rtools/.
    
     v Updated metadata database: 4.56 MB in 16 files.
    
     i R 4.2 windows packages are missing from Bioconductor
     i Updating metadata database
     v Updating metadata database ... done
    
     ══ Skipped tests ═══════════════════════════════════════════════════════════════
     • Offline (32)
     • On CRAN (42)
     • On Windows (2)
     • empty test (5)
     • external R does not work (1)
    
     ══ Failed tests ════════════════════════════════════════════════════════════════
     ── Error (test-install-binary.R:4:3): install_binary ───────────────────────────
     Error: Could not find tools necessary to compile a package
     Call `pkgbuild::check_build_tools(debug = TRUE)` to diagnose the problem.
     Backtrace:
     █
     1. └─pkgdepends:::binary_test_package("foo") test-install-binary.R:4:2
     2. ├─withr::with_path(...) C:\msys64\home\tomas\ucrt3\svn\ucrt3\r_packages\pkgcheck\CRAN\pkgdepends\pkgdepends.Rcheck\tests\testthat\helper-install.R:38:2
     3. │ └─base::force(code)
     4. └─pkgbuild::build(file.path(tmp, name), binary = TRUE, quiet = TRUE)
     5. └─pkgbuild:::build_setup(...)
     6. └─pkgbuild:::build_setup_binary(path, dest_path, args, needs_compilation)
     7. └─pkgbuild::check_build_tools(quiet = TRUE)
     ── Error (test-install-metadata.R:4:3): install_binary metadata ────────────────
     Error: Could not find tools necessary to compile a package
     Call `pkgbuild::check_build_tools(debug = TRUE)` to diagnose the problem.
     Backtrace:
     █
     1. └─pkgdepends:::binary_test_package("foo") test-install-metadata.R:4:2
     2. ├─withr::with_path(...) C:\msys64\home\tomas\ucrt3\svn\ucrt3\r_packages\pkgcheck\CRAN\pkgdepends\pkgdepends.Rcheck\tests\testthat\helper-install.R:38:2
     3. │ └─base::force(code)
     4. └─pkgbuild::build(file.path(tmp, name), binary = TRUE, quiet = TRUE)
     5. └─pkgbuild:::build_setup(...)
     6. └─pkgbuild:::build_setup_binary(path, dest_path, args, needs_compilation)
     7. └─pkgbuild::check_build_tools(quiet = TRUE)
    
     [ FAIL 2 | WARN 0 | SKIP 82 | PASS 899 ]
     Error: Test failures
     Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.2
Check: PDF version of manual
Result: WARN
    LaTeX errors when creating PDF version.
    This typically indicates Rd problems.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.2
Check: PDF version of manual without hyperrefs or index
Result: ERROR
    Re-running with no redirection of stdout/stderr.
Flavor: r-devel-windows-x86_64-gcc10-UCRT